VC驿站

 找回密码
 加入驿站

QQ登录

只需一步,快速开始

搜索
查看: 148|回复: 1

[原创] deepin系统下C++编程系列(科普,非精通)2.必要工具安装(2)

[复制链接]
04_avatar_middle
最佳答案
7 
online_vip 发表于 2020-3-13 22:45:18 | 显示全部楼层 |阅读模式
前面我们安装了gcc这个编译器,下面我们来安装集成开发环境,这个看个人的喜好,现在能用来做集成开发环境的编译工具很多,像古老的vi和vim,还有最新的微软发布的vscode,但是我推荐2款集成开发环境,codeblocks和codelite,这个2个软件都很好用,我们先安装codeblocks

安装命令如下:

sudo apt-get install codeblocks

官方网站上发布的最新版本是17.12,但是Linux系统下可以直接安装的却是上个版本,也就是16.12,

现在主程序已经安装,但是这还是不够的,还需要安装一个东西,
sudo apt-get install codeblocks-contrib
这个是codeblocks的图形设计工具,如果不安装就无法方便的做GUI设计,当然,如果不安装也可以用wxFormbuilder这个工具来设计界面。

安装完成,我们打开看看
16.01?见鬼。如果想安装17.12需要自己编译codeblocks的源码来安装,而且现在的Linux系统不支持codeblocks-contrib,所以,还是顺其自然吧。
当然,现在想做GUI程序就只能先做GTK界面,很不方便,我更喜欢用wxWidgets。
这个需要自己下载然后编译安装,我们先不说这个,先安装另一个IDE
codelite
为毛这么慢?
先暂停下,刚才看了下,在deepin下安装codelite居然要1个多小时,崩溃,我干脆进ubuntu系统下演示codelite好了。
刚安装好是英文界面,我们设置成中文
它和codeblocks不一样,codeblocks是直接可以创建一个工程,而codelite则需要先创建一个工作空间,然后在这个工作空间下创建工程。
可以看到,codelite支持的编译器,这些如果安装了,可以直接用,而不用太过麻烦的去配置。


链接: https://pan.baidu.com/s/1Y5TvlHvI3ttMdHFJDWixNQ 提取码: n35d




上一篇:deepin系统下C++编程系列(科普,非精通)2.必要工具安装(1)
下一篇:deepin系统下C++编程系列(科普,非精通)2.3mysql相关
83_avatar_middle
最佳答案
0 
在线会员 发表于 2020-3-14 14:23:30 来自手机 | 显示全部楼层
多谢楼主分享。。。
您需要登录后才可以回帖 登录 | 加入驿站 qq_login

本版积分规则

×【发帖 友情提示】
1、请回复有意义的内容,请勿恶意灌水;
2、纯数字、字母、表情等无意义的内容系统将自动删除;
3、若正常回复后帖子被自动删除,为系统误删的情况,请重新回复其他正常内容或等待管理员审核通过后会自动发布;
4、感谢您对VC驿站一如既往的支持,谢谢合作!

关闭

站长提醒上一条 /2 下一条

QQ|小黑屋|手机版|VC驿站 ( 辽ICP备09019393号 )|网站地图wx_jqr

GMT+8, 2020-9-29 14:22

Powered by CcTry.CoM

© 2009-2020 cctry.com

快速回复 返回顶部 返回列表