VC驿站

 找回密码
 加入驿站

QQ登录

只需一步,快速开始

搜索
查看: 223|回复: 6

[交流] VS2010怎么打开高版本工程或解决方案

[复制链接]
61_avatar_middle
最佳答案
0 
在线会员 发表于 2021-4-7 16:30:44 | 显示全部楼层 |阅读模式
最近用VS2010 需要打开2017的工程 然后就报错,因为每个版本的集成开发环境需要空间较大 所以想能用2010否打开高版本的工程及解决方案,谢谢。




上一篇:c++学习之路的点滴记录(利用基础语法)打造通讯录系统,大牛飘过
下一篇:c++学习之路 三只小猪称体重,基础语法,大牛飘过
70_avatar_middle
最佳答案
43 
在线会员 发表于 2021-4-7 18:13:58 | 显示全部楼层
1.修改sln文件 和 项目文件
https://www.cnblogs.com/pertor/p/8961180.html

2.vs2010不支持c++11即使打开了也不一定能编译成功

3.建议装一个vs2019兼容所有低级版本
58_avatar_middle
最佳答案
50 
online_vip 发表于 2021-4-7 22:51:01 | 显示全部楼层
VS2010怎么打开高版本工程或解决方案

在VS2017配置一下环境,在编译,把工程用VS2010打开试试。
61_avatar_middle
最佳答案
0 
ico_lz  楼主| 发表于 2021-4-8 10:18:26 | 显示全部楼层
好的 先谢谢各位了!
61_avatar_middle
最佳答案
0 
ico_lz  楼主| 发表于 2021-4-8 10:19:33 | 显示全部楼层
1>------ 已启动生成: 项目: Test, 配置: Debug x64 ------
1>生成启动时间为 2021/4/8 9:49:58。
1>项目文件包含 ToolsVersion="15.0"。此工具集可能未知或缺失。在这种情况下,通过安装 MSBuild 的正确版本,或许可以解决此问题。否则,该 build 可能已因策略原因而被强制为某个特定 ToolsVersion。将该项目视为其已具有 ToolsVersion="4.0"。有关详细信息,请参阅 http://go.microsoft.com/fwlink/?LinkId=291333。
1>C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\Platforms\x64\Microsoft.Cpp.x64.Targets(507,5): error MSB8008: 指定的平台工具集(v141)未安装或无效。请确保选择受支持的 PlatformToolset 值。
1>
1>生成失败。
1>
1>已用时间 00:00:00.19
========== 生成: 成功 0 个,失败 1 个,最新 0 个,跳过 0 个 ==========
61_avatar_middle
最佳答案
0 
ico_lz  楼主| 发表于 2021-4-8 10:20:46 | 显示全部楼层
出现这种情况怎么处理呢?我正常按装旗舰版
99_avatar_middle
最佳答案
0 
在线会员 发表于 2021-4-8 19:47:23 | 显示全部楼层
都是高手,学习了
您需要登录后才可以回帖 登录 | 加入驿站 qq_login

本版积分规则

×【发帖 友情提示】
1、请回复有意义的内容,请勿恶意灌水;
2、纯数字、字母、表情等无意义的内容系统将自动删除;
3、若正常回复后帖子被自动删除,为系统误删的情况,请重新回复其他正常内容或等待管理员审核通过后会自动发布;
4、感谢您对VC驿站一如既往的支持,谢谢合作!

关闭

站长提醒上一条 /2 下一条

QQ|小黑屋|手机版|VC驿站 ( 辽ICP备09019393号-4 )|网站地图wx_jqr

GMT+8, 2021-4-23 04:43

Powered by CcTry.CoM

© 2009-2021 cctry.com

快速回复 返回顶部 返回列表